SharePoint 2013 Custom Workflow Actions Don’t Run Properly (Could not deserialize object)!

By |2019-03-11T11:22:44+00:00March 11th, 2019|Sharepoint|0 Comments

We’ve recently encountered an issue whereby workflows on a SharePoint 2013 environment will stop running as expected and kick up the error “Could not deserialize object. The type ‘<Workflowname>.<Workflow actions>.<workflow Action>’ could not be resolved.”. This gave us quite the headache for a long while until we finally manged to find the root cause of this.

To fix this do the following:

1) Open up your web config file (usually stored C:\inetpub\wwwroot\wss\VirtualDirectories\<port name used>).

2) Find

<System.Workflow.ComponentModel.WorkflowCompiler>

<AuthorizedTypes>

<TargetFx version=”v4.0″>

3) If you look just below this you should then see the below:

</targetFx>

</authorizedTypes>

<authorizedRuleTypes>

4) This is where your workflow dependencies will show and what is causing the issue. These will start with the following:

5) To fix this simply right click cut all of these and paste them above </targetFx>, for more clarification these will now show in between:

 

<System.Workflow.ComponentModel.WorkflowCompiler>

<AuthorizedTypes>

<TargetFx version=”v4.0″>

and

</targetFx>

6) Depending on how big your SharePoint Farm it is best to maker sure all your web config files show the same thing therefore you will simply need to repeat the process.

7) Do an IISReset in CMD and away you go!

Leave A Comment

like what you see? 

Sign-up to our newsletter and never miss out on the latest blogs, events and tech news from the world of risual
SUBSCRIBE!
Give it a try, you can unsubscribe anytime.