Issue Reinstalling SharePoint after uninstalling Office Web Apps

2017-12-07T13:53:49+00:00 April 18th, 2011|Office 365, Sharepoint|

Came across an issue today where we were unable to reinstall SharePoint 2010 with the following error “The install in progress conflicts with a previously installed Microsoft Office 2010 Server product”

image

Previously office web apps was also installed on SharePoint but was remove via Add/Remove programs successfully. However i did a quick search in the registry and found that it still looked like some components remained from Office Web Apps. (HKLMSoftwareMicrosoftWindowsCurrentVersionInstallerUserDataS-1-5-18)

image

I then decided to run the uninstall strings to remove these components (MSIEXEC Commands below)

Full List

Microsoft Office Web Apps Proof (Arabic) 2010
MsiExec.exe /X{90140000-1141-0401-1000-0000000FF1CE}

Microsoft Office Web Apps Proof (German) 2010
MsiExec.exe /X{90140000-1141-0407-1000-0000000FF1CE}

Microsoft Office Web Apps Proof (English) 2010
MsiExec.exe /X{90140000-1141-0409-1000-0000000FF1CE}

Microsoft Office Web Apps Proof (Russian) 2010
MsiExec.exe /X{90140000-1141-0419-1000-0000000FF1CE}

Microsoft Office Web Apps Proof (Spanish) 2010
MsiExec.exe /X{90140000-1141-0C0A-1000-0000000FF1CE}

Microsoft Office Web Apps Proof (French) 2010
MsiExec.exe /X{90140000-1141-040C-1000-0000000FF1CE}

Microsoft Office Web Apps Web Front End Components
MsiExec.exe /X{90140000-1144-0000-1000-0000000FF1CE}

Microsoft Office Web Apps English Language Pack
MsiExec.exe /X{90140000-1145-0409-1000-0000000FF1CE}

Microsoft Office Web Apps Application Server Components
MsiExec.exe /X{90140000-112D-0000-1000-0000000FF1CE}

After this i could re-install SharePoint 2010 with no errors Smile

image